As the title above, I think you will encounter the same problem when trying to install software on vps that using OpenVZ

I encounter this problem during my honeypot installation on my new vps when I try to install python2.7-dev onto Ubuntu 12.04.

The error shows something like this;

libc6-dev : Depends: libc6 (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10+openvz0 is to be installed
E: Unable to correct problems, you have held broken packages.

To solve it, modify the file at /etc/apt/preferences.d/99ovz-libc-pin

Replace from this line:

libc-bin libc6

become this line;

libc-bin libc6 libc6-dev libc-dev-bin

Save it, update & enjoy. 🙂

By zam

Related Post

3 thoughts on “Error when installing python2.7-dev on Ubuntu 12.04 (OpenVZ)”
  1. Thanks! I had this pin set on my 12.04 OpenVZ VPS and couldn’t install php5-dev. After applying the change you detailed here, it worked fine. Thanks a lot!

  2. Ah, by the way, the iframe is too short in your comment section. I can see why no one has commented saying thanks yet. I resized it with the Chrome Dev Tools so I could see and and answer the CAPTCHA.

  3. welcome K!
    I’m glad it helps for you.
    And also thanks for mind me about my blog template.
    I will adjust it properly.

    Thanks again. 🙂

Any Comments?

This site uses Akismet to reduce spam. Learn how your comment data is processed.